Results 1 to 9 of 9

Thread: Marshydro ts600 faulty leds

  1. #1

    Join Date
    May 2020
    Posts
    30
    Thanks
    32
    Thanked 96 Times in 30 Posts

    Default Marshydro ts600 faulty leds

    I baught a ts600 from ebay brand new from a supplier and after only 2 months randomly different leds will not light up but its not always the same ones and some are on full power some dim, sometimes all dim etc. Also i got one hell of a shock from it when i first noticed it was dim i touched it and boom! Anyway the seller replied with some rediculous answers saying that its normal and if i wanted to upgrade to a ts1000 they would give me a bit of money off as the ts600 i have in a 40x40 tent is apparantly not enough! After some harsh words back and forward they stopped treating me like a child and have sent me a replacement(i havent received it yet).

    Im just wondering if anybody else has had any issues with the ts600? And if anybody has a clue what could be the issue with the unit and if i could poss repair it? Wouldnt hurt to have another working light.

    Thanks in advance
    Will

  2. The Following 3 Users Say Thank You to pppass For This Useful Post:

    Greengrass (08-05-20), hotshot (08-05-20), jingo (08-05-20)

  3. #2

    Join Date
    Apr 2014
    Location
    USA
    Posts
    4,894
    Thanks
    7,424
    Thanked 11,760 Times in 3,978 Posts

    Default

    I haven't owned a Mars since the Mars II and that was exactly the way mine were. If it is dimming down and giving you a shock I would say the fix for that would be quite easy. More than likely, if you take the light apart you'll find probably about a half a dozen drivers in there. One of those drivers is probably just randomly grounding out. Shouldn't be very hard to find. You could also be just plain burning out lenses or LEDs if they're going dim or dark and staying that way.

    In the long run, you will just be replacing those mars with something better. I'm not sure what to tell you to use, I bought all my LEDs that I currently run used. They are professional greenhouse lights I use the lumigrow pros, I prefer the 325 watt models. about there's still available I picked up mine for between 3 and $500 a pink stock eBay years ago.

  4. The Following 2 Users Say Thank You to jingo For This Useful Post:

    hotshot (08-05-20), M_C (08-05-20)

  5. #3

    Join Date
    Mar 2009
    Posts
    53,702
    Thanks
    142,318
    Thanked 150,841 Times in 43,293 Posts

    Default

    It's not the first time Mars have tried to fob off their customers.... When they had issues with their Hydro II series & offered the customer a discount against their new lights (or offered to send the LED so the customer could repair it themself!)

    Throw it in the bin mate, Mars will just continue giving you the runaround

  6. The Following User Says Thank You to M_C For This Useful Post:

    hotshot (08-05-20)

  7. #4

    Join Date
    May 2020
    Posts
    30
    Thanks
    32
    Thanked 96 Times in 30 Posts

    Default

    Its disappointing tbh i was happy with the cheap and cheerful nature of it, it was cheap and just did what it was supposed to but only for a short period. I guess you get what you pay for, but im a bit of a tight ar5e, i have to be at the minute i got laid off before xmas and with the whole covid situation things arent looking great. Hopefully the new unit will turn up today and last longer than the last one. I think ill do as jingo said and pull it apart and if i cant see anything obvious then bin the hunk of junk like you say m_c.

    Unfortunately atm my budget keeps my options limited to this kind of quality i guess, defo limited to this price range though

    Cheers
    Will

  8. The Following 3 Users Say Thank You to pppass For This Useful Post:

    hotshot (08-05-20), jingo (08-05-20), M_C (08-05-20)

  9. #5

    Join Date
    Mar 2009
    Posts
    53,702
    Thanks
    142,318
    Thanked 150,841 Times in 43,293 Posts

    Default

    Mars used to be a sponsor here. They pulled that very same stunt. Let's just say it wasn't the worst thing they did here & ended up with their rep banned

  10. The Following User Says Thank You to M_C For This Useful Post:

    hotshot (08-05-20)

  11. #6

    Join Date
    Nov 2017
    Location
    Here and there
    Posts
    8,964
    Thanks
    22,746
    Thanked 35,179 Times in 8,573 Posts

    Default

    Did you buy from a Mars reseller as they offer a 3 year warranty?

    I tried to find the cause of your problems from others online but struggled

  12. The Following User Says Thank You to gardro For This Useful Post:

    hotshot (08-05-20)

  13. #7

    Join Date
    May 2020
    Posts
    30
    Thanks
    32
    Thanked 96 Times in 30 Posts

    Default

    Can i name the seller here? I recieved a new one today which works as it should, they are brand new, I'm not sure if they are an approved seller or re-seller of marshydro but they have (as far as i know) the full mars range in stock on their ebay store. I'm an easy going person and their customer service skills or lack of really grinded my gears.

    I havent touched the damaged one yet but the way i see it is its just wasting space sitting there and if its an easy fix then i could really do with selling it as long as it works fine, because moneys tight right now!

  14. The Following User Says Thank You to pppass For This Useful Post:

    hotshot (10-05-20)

  15. #8

    Join Date
    Mar 2009
    Posts
    53,702
    Thanks
    142,318
    Thanked 150,841 Times in 43,293 Posts

    Default

    We'd prefer that you didn't name a reseller, their resellers are usually Mars connected!
    "The purpose of our lives is to be happy."
    (Dalai Lama)

  16. The Following User Says Thank You to M_C For This Useful Post:

    hotshot (10-05-20)

  17. #9

    Join Date
    May 2020
    Posts
    30
    Thanks
    32
    Thanked 96 Times in 30 Posts

    Default

    No problem, its just an ebay power seller but i think they dont just stock mars im sure they had a few brands.

    Tried to upload a pic of light but im using chrome on android and when i choose the file i cant seem to se an 'ok' button or upload whatever. Seems like a waste that light just kicking around taking up space so tomorrow I think i will take it apart and have a fiddle with it, i have no idea what im looking at/for but if its going to be thrown out anyway why not have a go

  18. The Following 2 Users Say Thank You to pppass For This Useful Post:

    hotshot (12-05-20), M_C (12-05-20)

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


THCtalk.com Disclaimer - You must be over 18 years old to view/use this site .THCtalk.com does not encourage growing Cannabis or possessing Cannabis. Learning how to grow Cannabis instructions should be for educational purposes only. All Information contained in this web site is for: Historical reference, Scientific reference and Educational purposes only. Visitors to this website are advised against breaking the law as It is illegal to smoke, grow, or possess cannabis in the UK and some US States