Results 1 to 4 of 4

Thread: Plug burnt

  1. #1

    Join Date
    Oct 2010
    Location
    Tulare, Cali, west of Fresno
    Posts
    2,339
    Thanks
    1,103
    Thanked 1,314 Times in 802 Posts
    Provided Answers: 8

    Default Unanswered: Plug burnt

    I have a 600w dimmable lumetek ballast on a lumii pkug n grow heavy duty relay contactor timer..

    Used it 4 years now. Bulbs 6month old and whistlibg so i got a new befor eit pops...

    Pluggin back in i notice that the plug and grow timer is bloody got burnt plastic marks where the main plug pin goes in andhas a seal...

    There is small scorch marks on my ballast pin close the the base plastic but not surneif thats stuck on from timer burnt?


    Why has it burnt im not gona use it..

    I have anothe 1 running next to it... The timers are 2 month old. Only.

    Are they a fire risk? Wtf do i do? Am week 7 flower gona manual it for now but i wana make sure the ballasts plugs ok and its defo from the timer and not the ballast casued it?Click image for larger version. 

Name:	20200525_221909.jpg 
Views:	19 
Size:	37.8 KB 
ID:	383637Click image for larger version. 

Name:	20200525_221909.jpg 
Views:	19 
Size:	37.8 KB 
ID:	383637
    Last edited by DrGreen; 25-05-20 at 09:21 PM.

  2. The Following 3 Users Say Thank You to DrGreen For This Useful Post:

    Gasher90 (26-05-20), hotshot (25-05-20), Mac (26-05-20)

  3. #2

    Join Date
    Mar 2009
    Posts
    53,702
    Thanks
    142,318
    Thanked 150,841 Times in 43,293 Posts
    Provided Answers: 496

    Default

    Send them back!
    "The purpose of our lives is to be happy."
    (Dalai Lama)

  4. The Following 3 Users Say Thank You to M_C For This Useful Post:

    Gasher90 (26-05-20), hotshot (25-05-20), Mac (26-05-20)

  5. #3

    Join Date
    Oct 2010
    Location
    Tulare, Cali, west of Fresno
    Posts
    2,339
    Thanks
    1,103
    Thanked 1,314 Times in 802 Posts
    Provided Answers: 8

    Default

    Quote Originally Posted by M_C View Post
    Send them back!
    Doing it... Mailed em both..

    Where do i stand? Do i use tue ballast manual and assume its the timer?

    Small black mark on plug basebin sameblocation as burnt plastic on timer so guessing timer rubbed on it

  6. The Following 3 Users Say Thank You to DrGreen For This Useful Post:

    Gasher90 (26-05-20), hotshot (25-05-20), Mac (26-05-20)

  7. #4

    Join Date
    Jul 2018
    Posts
    224
    Thanks
    416
    Thanked 422 Times in 215 Posts

    Default

    Hi that sucks man, it’s hard to say which it is but something is causing resistance to high current, check your plug mate inside (if it’s not a fitted plug) and just make sure all connections are still right in their as this can be caused by a loose connection, but from why can be seen in the picture bud I’d say it was the timer, hope this helps mate but please check your plug as “IT WILL” cause a fire, best safe than sorry, stay safe Grow strong!

  8. The Following User Says Thank You to Gasher90 For This Useful Post:

    hotshot (27-05-20)

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


THCtalk.com Disclaimer - You must be over 18 years old to view/use this site .THCtalk.com does not encourage growing Cannabis or possessing Cannabis. Learning how to grow Cannabis instructions should be for educational purposes only. All Information contained in this web site is for: Historical reference, Scientific reference and Educational purposes only. Visitors to this website are advised against breaking the law as It is illegal to smoke, grow, or possess cannabis in the UK and some US States